import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\.0+,|,0+(?=\\.)";
final String string = "2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101\n"
+ "0.001,-0.03\n"
+ "2,3,-4,0,0,.03,2.01,.001,-.03,101\n";
final String subst = ",";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}