use strict;
my $str = '2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101
0.001,-0.03
2,3,-4,0,0,.03,2.01,.001,-.03,101
';
my $regex = qr/\.0+,|,0+(?=\.)/p;
my $subst = ',';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";