import re
regex = re.compile(r"\.0+,|,0+(?=\.)")
test_str = ("2.0,3.00,-4.0,0.00,-0.00,0.03,2.01,0.001,-0.03,101\n"
"0.001,-0.03\n"
"2,3,-4,0,0,.03,2.01,.001,-.03,101\n")
subst = ","
result = regex.sub(subst, test_str)
if result:
print(result)