using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?i)[A-Z]+)c";
string input = @"abcABC
说明:局部(ab)的大小写被忽略了,(?i)的作用范围在分组1 内";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}