const regex = /((?i)[A-Z]+)c/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((?i)[A-Z]+)c', 'gm')
const str = `abcABC
说明:局部(ab)的大小写被忽略了,(?i)的作用范围在分组1内`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}