import re
regex = re.compile(r"((?i)[A-Z]+)c", flags=re.MULTILINE)
test_str = ("abcABC\n\n"
"说明:局部(ab)的大小写被忽略了,(?i)的作用范围在分组1内")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")