const regex = /^([^?!]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^([^?!]*)', 'gm')
const str = `"hello, i am working through an r workbook. I am doing a regex expression.", "hi, how are you? I am great working through r"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}