$re = '/^([^?!]*)/m';
$str = '"hello, i am working through an r workbook. I am doing a regex expression.", "hi, how are you? I am great working through r"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);