re = /^([^?!]*)/m
str = '"hello, i am working through an r workbook. I am doing a regex expression.", "hi, how are you? I am great working through r"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end