import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:(?<mcversion>\\d+\\.\\d+(?:\\.\\d+){0,1})-){0,1}(?<fullver>(?<version>\\d+(?:\\.\\d+)*)(?:[-+](?<extra>.*))?)";
final String string = "Raw Version:\n"
+ "1.0.0\n"
+ "1.2.3.4\n"
+ "1.0\n\n"
+ "Prefixed with version:\n"
+ "1.7.10-1.2.3\n"
+ "1.8.1-10.0.0.1\n"
+ "1.10.10-2\n"
+ "1.5-4.63.2\n\n"
+ "Extra Information\n"
+ "1.6-4.4.4.4-SNAPSHOT-BULLSHIT\n"
+ "1.6-SNAPSHOT-BULLSHIT\n\n"
+ "With Metadata Support\n"
+ "1.0.0-alpha+001\n"
+ "1.0.0+20130313144700\n"
+ "1.0.0-beta+exp.sha.5114f85";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}