# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:(?<mcversion>\d+\.\d+(?:\.\d+){0,1})-){0,1}(?<fullver>(?<version>\d+(?:\.\d+)*)(?:[-+](?<extra>.*))?)"
test_str = ("Raw Version:\n"
"1.0.0\n"
"1.2.3.4\n"
"1.0\n\n"
"Prefixed with version:\n"
"1.7.10-1.2.3\n"
"1.8.1-10.0.0.1\n"
"1.10.10-2\n"
"1.5-4.63.2\n\n"
"Extra Information\n"
"1.6-4.4.4.4-SNAPSHOT-BULLSHIT\n"
"1.6-SNAPSHOT-BULLSHIT\n\n"
"With Metadata Support\n"
"1.0.0-alpha+001\n"
"1.0.0+20130313144700\n"
"1.0.0-beta+exp.sha.5114f85")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.