import Foundation
let pattern = #"(?:(?<mcversion>\d+\.\d+(?:\.\d+){0,1})-){0,1}(?<fullver>(?<version>\d+(?:\.\d+)*)(?:[-+](?<extra>.*))?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Raw Version:
1.0.0
1.2.3.4
1.0
Prefixed with version:
1.7.10-1.2.3
1.8.1-10.0.0.1
1.10.10-2
1.5-4.63.2
Extra Information
1.6-4.4.4.4-SNAPSHOT-BULLSHIT
1.6-SNAPSHOT-BULLSHIT
With Metadata Support
1.0.0-alpha+001
1.0.0+20130313144700
1.0.0-beta+exp.sha.5114f85
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)