#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)(?=(\d{2}\/\d{2}\/\d{4}))(?=([^\n]+\n)+[^\n]*BNA\sCNTRS[^=\n]*\n)([^\n]+\n)+"
Local $sString = "*044*05/02/2013*14:24*" & @CRLF & _
"*1234*1*(Iw(1*0, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"OPERATION OK" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*044*05/02/2013*14:24*" & @CRLF & _
"*1234*1*(Iw(1*0, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*044*05/02/2013*14:24*" & @CRLF & _
"*1234*1*(Iw(1*0, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"OPERATION OK" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[0r(1)2[000p[040qe1w3h162*054*05/04/2013*14:27*" & @CRLF & _
"*1234*1*(Iw(1*0, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*055*05/04/2013*14:27*" & @CRLF & _
"*1234*1*(Iw(1*0, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"OPERATION OK" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[020t*057*05/04/2013*14:27*" & @CRLF & _
"[05p" & @CRLF & _
" BNA CNTRS" & @CRLF & _
" LAST CLEARED : 00/00/00 00:00" & @CRLF & _
" COUNT " & @CRLF & _
" ENCASHED 141" & @CRLF & _
"" & @CRLF & _
"[0r(1)2[000p[040qe1w3h162*065*05/05/2013*14:30*" & @CRLF & _
"*1234*1*(Iw(1*0, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"OPERATION OK" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"*071*05/06/2013*14:31*" & @CRLF & _
"*1234*1*(Iw(1*1, M-00, R-10011002100310041" & @CRLF & _
"A/C " & @CRLF & _
"CUSTOMER CANCEL" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"[020t*076*05/06/2013*14:32*" & @CRLF & _
"[05p" & @CRLF & _
" BNA CNTRS" & @CRLF & _
" LAST CLEARED : 05/04/13 14:28" & @CRLF & _
" COUNT " & @CRLF & _
" ENCASHED 11"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")