# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?=(\d{2}\/\d{2}\/\d{4}))(?=([^\n]+\n)+[^\n]*BNA\sCNTRS[^=\n]*\n)([^\n]+\n)+"
test_str = ("*044*05/02/2013*14:24*\n"
"*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
"A/C \n"
"OPERATION OK\n\n\n"
"*044*05/02/2013*14:24*\n"
"*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
"A/C \n\n\n"
"*044*05/02/2013*14:24*\n"
"*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
"A/C \n"
"OPERATION OK\n\n\n"
"[0r(1)2[000p[040qe1w3h162*054*05/04/2013*14:27*\n"
"*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
"A/C \n\n\n"
"*055*05/04/2013*14:27*\n"
"*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
"A/C \n"
"OPERATION OK\n\n\n"
"[020t*057*05/04/2013*14:27*\n"
"[05p\n"
" BNA CNTRS\n"
" LAST CLEARED : 00/00/00 00:00\n"
" COUNT \n"
" ENCASHED 141\n\n"
"[0r(1)2[000p[040qe1w3h162*065*05/05/2013*14:30*\n"
"*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
"A/C \n"
"OPERATION OK\n\n\n"
"*071*05/06/2013*14:31*\n"
"*1234*1*(Iw(1*1, M-00, R-10011002100310041\n"
"A/C \n"
"CUSTOMER CANCEL\n\n\n"
"[020t*076*05/06/2013*14:32*\n"
"[05p\n"
" BNA CNTRS\n"
" LAST CLEARED : 05/04/13 14:28\n"
" COUNT \n"
" ENCASHED 11")
matches = re.finditer(regex, test_str, re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.