import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=(\\d{2}\\/\\d{2}\\/\\d{4}))(?=([^\\n]+\\n)+[^\\n]*BNA\\sCNTRS[^=\\n]*\\n)([^\\n]+\\n)+";
final String string = "*044*05/02/2013*14:24*\n"
+ "*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
+ "A/C \n"
+ "OPERATION OK\n\n\n"
+ "*044*05/02/2013*14:24*\n"
+ "*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
+ "A/C \n\n\n"
+ "*044*05/02/2013*14:24*\n"
+ "*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
+ "A/C \n"
+ "OPERATION OK\n\n\n"
+ "[0r(1)2[000p[040qe1w3h162*054*05/04/2013*14:27*\n"
+ "*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
+ "A/C \n\n\n"
+ "*055*05/04/2013*14:27*\n"
+ "*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
+ "A/C \n"
+ "OPERATION OK\n\n\n"
+ "[020t*057*05/04/2013*14:27*\n"
+ "[05p\n"
+ " BNA CNTRS\n"
+ " LAST CLEARED : 00/00/00 00:00\n"
+ " COUNT \n"
+ " ENCASHED 141\n\n"
+ "[0r(1)2[000p[040qe1w3h162*065*05/05/2013*14:30*\n"
+ "*1234*1*(Iw(1*0, M-00, R-10011002100310041\n"
+ "A/C \n"
+ "OPERATION OK\n\n\n"
+ "*071*05/06/2013*14:31*\n"
+ "*1234*1*(Iw(1*1, M-00, R-10011002100310041\n"
+ "A/C \n"
+ "CUSTOMER CANCEL\n\n\n"
+ "[020t*076*05/06/2013*14:32*\n"
+ "[05p\n"
+ " BNA CNTRS\n"
+ " LAST CLEARED : 05/04/13 14:28\n"
+ " COUNT \n"
+ " ENCASHED 11";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}