using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-*]*\s*\b(edit|update)\b(\s*#?[0-9]+)?\s*:+\s*[-*]*|[-*]+\s*\b(edit|update)\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)";
string input = @"UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
I'm going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
**Edit: More precise explanation:**
***editprofile.js***
-- Edit --";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}