// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)([-*]*\s*\b(edit|update)\b(\s*#?[0-9]+)?\s*:+\s*[-*]*|[-*]+\s*\b(edit|update)\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)").unwrap();
let string = "UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
I'm going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
**Edit: More precise explanation:**
***editprofile.js***
-- Edit --";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}