$re = '/([-*]*\s*\b(edit|update)\b(\s*#?[0-9]+)?\s*:+\s*[-*]*|[-*]+\s*\b(edit|update)\b(\s*#?[0-9]+)?\s*:*\s*[-*]+)/im';
$str = 'UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
I\'m going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
**Edit: More precise explanation:**
***editprofile.js***
-- Edit --';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);