using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"([-*]+[\t ]*\b(edit|update)\b([\t ]*#?[0-9]+)?[\t ]*:*[\t ]*[-*]+|[\t ]*\b(edit|update)\b([\t ]*#?[0-9]+)?\s*:+[\t ]*)";
string input = @"Match & remove ""edit"" and ""update"", leaving surrounding useful text. If formatting is useful without the removed text, leave it; otherwise remove it, too. Don't remove trailing spaces or line feeds.
UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
-- Edit --
**Edit: More precise explanation:**
-----------------------------------------------
Since ""edit"" and ""update"" are not inherently bad words, leave normal use of them:
I'm going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
***editprofile.js***
";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}