const regex = /([-*]+[\t ]*\b(edit|update)\b([\t ]*#?[0-9]+)?[\t ]*:*[\t ]*[-*]+|[\t ]*\b(edit|update)\b([\t ]*#?[0-9]+)?\s*:+[\t ]*)/gim;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-*]+[\\t ]*\\b(edit|update)\\b([\\t ]*#?[0-9]+)?[\\t ]*:*[\\t ]*[-*]+|[\\t ]*\\b(edit|update)\\b([\\t ]*#?[0-9]+)?\\s*:+[\\t ]*)', 'gim')
const str = `Match & remove "edit" and "update", leaving surrounding useful text. If formatting is useful without the removed text, leave it; otherwise remove it, too. Don't remove trailing spaces or line feeds.
UPDATE: changed the example to show use,
Edit: Something different
**EDIT** I really mean this one...
Edit #2:
-- Edit --
**Edit: More precise explanation:**
-----------------------------------------------
Since "edit" and "update" are not inherently bad words, leave normal use of them:
I'm going to edit my question. Better not match any of this update here.
Edit the file to...
Update for anyone who cares:
Update for nobody.
***editprofile.js***
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}