import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([-*]+[\\t ]*\\b(edit|update)\\b([\\t ]*#?[0-9]+)?[\\t ]*:*[\\t ]*[-*]+|[\\t ]*\\b(edit|update)\\b([\\t ]*#?[0-9]+)?\\s*:+[\\t ]*)";
final String string = "Match & remove \"edit\" and \"update\", leaving surrounding useful text. If formatting is useful without the removed text, leave it; otherwise remove it, too. Don't remove trailing spaces or line feeds.\n\n"
+ "UPDATE: changed the example to show use,\n\n"
+ "Edit: Something different\n\n"
+ "**EDIT** I really mean this one...\n\n"
+ "Edit #2: \n\n"
+ "-- Edit --\n\n"
+ "**Edit: More precise explanation:**\n\n"
+ "-----------------------------------------------\n"
+ "Since \"edit\" and \"update\" are not inherently bad words, leave normal use of them:\n\n"
+ "I'm going to edit my question. Better not match any of this update here.\n\n"
+ "Edit the file to...\n\n"
+ "Update for anyone who cares:\n\n"
+ "Update for nobody.\n\n"
+ "***editprofile.js***\n";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}