re = /(\w+="[\w:\/.-]+")/
str = '<p><br></p><h1>A beautiful <a class="f-link" rel="nofollow" target="_blank" href="fake.com/abc.html">jQuery</a>; WYSIWYG text editor</h1><h3 class="text-light">Froala WYSIWYG Editor is built on the latest technologies and according to the latest industry trends.</h3><p><br></p><p><br></p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end