import Foundation
let pattern = #"(\w+="[\w:\/.-]+")"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"<p><br></p><h1>A beautiful <a class="f-link" rel="nofollow" target="_blank" href="fake.com/abc.html">jQuery</a>; WYSIWYG text editor</h1><h3 class="text-light">Froala WYSIWYG Editor is built on the latest technologies and according to the latest industry trends.</h3><p><br></p><p><br></p>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)