// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?U)<p>(.*)<\/p>").unwrap();
let string = "<p>Lorem ipsum dolor sit amet, ius ex tota iriure. Impetus viderer mel at, an probo novum vituperatoribus nec, ne est maiorum euripidis. Integre sanctus dolorem cu vim, ei solet albucius pri. Te minim novum recusabo mea, vim ut lucilius maluisset, zril invidunt singulis sed id.</p><p>In consul salutandi cum. Te salutatus mnesarchum scriptorem sea, audire suavitate signiferumque ne vel. Alienum adversarium mel an, ius nulla tacimates at. Mentitum persequeris suscipiantur ne pri, et nam laudem oportere.</p><p>Ea melius ullamcorper eum, his probo euripidis necessitatibus ei. Eu lorem interesset usu, labore urbanitas ea usu. His te alii diam atqui. Eum an sapientem sadipscing. Autem latine voluptatibus per in, usu movet invidunt laboramus ex. Ne vim civibus perpetua definiebas, mei at cibo sale contentiones, vel dicant bonorum in. His ex doming constituto.</p>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}