using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"9[5-9]\/[01][09]\/[0-3][0-9]";
string input = @" 95/20/12 94/01/01 99/12/31";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}