const regex = /9[5-9]\/[01][09]\/[0-3][0-9]/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('9[5-9]\\\/[01][09]\\\/[0-3][0-9]', 'g')
const str = ` 95/20/12 94/01/01 99/12/31`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}