$re = '/9[5-9]\/[01][09]\/[0-3][0-9]/';
$str = ' 95/20/12 94/01/01 99/12/31';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);