#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(#+.*?)With Space"
Local $sString = "#ThisIsaHashtagWith Space"
Local $sSubst = "$1WithSpace"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)