$re = '/^(#+.*?)With Space/m';
$str = '#ThisIsaHashtagWith Space';
$subst = "$1WithSpace";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;