$re = '/(?n)(common_group) (?<group_name>not_common_group) \1/';
$str = 'common_group not_common_group not_common_group';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);