import re
regex = re.compile(r"(?n)(common_group) (?<group_name>not_common_group) \1")
test_str = "common_group not_common_group not_common_group"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")