using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+(?:[.,]\d+)?)\h*x\h*(\d+(?:[.,]\d+)?)";
string input = @"10 x 2,5";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}