$re = '/(\d+(?:[.,]\d+)?)\h*x\h*(\d+(?:[.,]\d+)?)/';
$str = '10 x 2,5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);