package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d+(?:[.,]\d+)?)\h*x\h*(\d+(?:[.,]\d+)?)`)
var str = `10 x 2,5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}