using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<div class=""main"">(.*?)<\/div>";
string input = @"<div class=""main"">Dieser Text soll ausgelesen werden</div>Dieser Text soll NICHT ausgelesen werden</div>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}