re = /<div class="main">(.*?)<\/div>/m
str = '<div class="main">Dieser Text soll ausgelesen werden</div>Dieser Text soll NICHT ausgelesen werden</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end