$re = '/<div class="main">(.*?)<\/div>/m';
$str = '<div class="main">Dieser Text soll ausgelesen werden</div>Dieser Text soll NICHT ausgelesen werden</div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);