use strict;
my $str = 'path/to/folder/@here';
my $regex = qr/(?<![^\/])[^\/@][^\/]*/mp;
my $subst = 'a:$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";