import Foundation
let pattern = #"(?<![^\/])[^\/@][^\/]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"path/to/folder/@here"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"a:$0"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)