package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<a.*?href=['"](.*?)['"].*<\/a>`)
var str = `<a href="ссылка" target="">текст</a>
<a target="" href="ссылка" >текст</a>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}