re = /<a.*?href=['"](.*?)['"].*<\/a>/
str = '<a href="ссылка" target="">текст</a>
<a target="" href="ссылка" >текст</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end