$re = '/<a.*?href=[\'"](.*?)[\'"].*<\/a>/';
$str = '<a href="ссылка" target="">текст</a>
<a target="" href="ссылка" >текст</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);