using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<drawing>(?:(?!</drawing>).)*?<Chart>.*?</drawing>";
string input = @"<drawing><some other tags><Picture><some other tags></drawing><drawing><some other tags><Chart><some other tags></drawing>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}