re = /<drawing>(?:(?!<\/drawing>).)*?<Chart>.*?<\/drawing>/
str = '<drawing><some other tags><Picture><some other tags></drawing><drawing><some other tags><Chart><some other tags></drawing>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end