$re = '/<drawing>(?:(?!</drawing>).)*?<Chart>.*?</drawing>/';
$str = '<drawing><some other tags><Picture><some other tags></drawing><drawing><some other tags><Chart><some other tags></drawing>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);