using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"""[^""]*""(*SKIP)(*F)|[\w.-]+";
string input = @"""Hello world!"" foo /(^*#&^$
""hello"" foobar ""hello"" FOO ""hello"" baz
Hi foo, I said ""hello"" $&@^$(@$)@$&*@(*$&";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}