re = /"[^"]*"(*SKIP)(*F)|[\w.-]+/
str = '"Hello world!" foo /(^*#&^$
"hello" foobar "hello" FOO "hello" baz
Hi foo, I said "hello" $&@^$(@$)@$&*@(*$&'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end