package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`"[^"]*"(*SKIP)(*F)|[\w.-]+`)
var str = `"Hello world!" foo /(^*#&^$
"hello" foobar "hello" FOO "hello" baz
Hi foo, I said "hello" $&@^$(@$)@$&*@(*$&`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}