const regex = /&N\|(.*|$)\//;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&N\\|(.*|$)\\\/', '')
const str = `Nr.: &N|1|2|3|4|5|6|7 / 8|9|10|11|12 / 2014`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}