import re
regex = re.compile(r"&N\|(.*|$)\/")
test_str = "Nr.: &N|1|2|3|4|5|6|7 / 8|9|10|11|12 / 2014"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")